The service disruption has been fully resolved. All systems are now operating normally.
While services remained available throughout the incident, some users experienced delays in processing. Our team has identified and addressed the root cause to prevent recurrence.
We sincerely apologize for any delays this caused and appreciate your patience as we worked through the resolution.
If you continue to experience any processing delays, please contact our support team.
Posted Feb 17, 2026 - 13:12 EST
Identified
We’ve implemented mitigation measures that have improved service and restored functionality. Our team is continuing to work to fully resolve the underlying issue and return to normal operations.
Posted Feb 17, 2026 - 11:38 EST
Investigating
We are currently experiencing a widespread performance issue affecting our services. Our engineering team is working urgently to identify the root cause and restore normal operations as quickly as possible.
What We Know So Far:
- The disruption appears to impact multiple systems and services. - Our team is fully engaged and working to resolve the issue.
We understand how critical our services are to you, and we deeply regret the inconvenience this may be causing. We will provide updates as soon as we have more information to share. Thank you for your patience and understanding during this time.
**User Impact**: Issues will be encountered by Truv’s client and users.
Posted Feb 17, 2026 - 11:10 EST
This incident affected: Public API, Dashboard, Truv Bridge, and Third Party API.